This project is read-only.

404 not working on DNN 7.2.2

Aug 1, 2014 at 8:42 PM
Edited Aug 1, 2014 at 8:49 PM
I installed the latest version of the DnnUrlManagement module in my DNN 7.2.2 installation. When i add the 404 redirect, i do see it's been changed in the database (portallocalization table), but is till get the server 404 error in stead of my dnn 404 error page.

I read a lot online about upgraded versions not having the 404 error page in site managment and fresh installs do. I've got a fresh DNN 7.2.2 install on windows server 2012 Datacenter and using sql 2012 express.

Anyone has any idea what is going on?
Aug 2, 2014 at 1:23 PM
I'm testing it and it seems to be working fine. I can change the 404 settings in either the Portal Settings UX or the X3 URL Management UX and it behaves as expected.

In fact, I should probably remove the UX from the X3 URL Management module since it is no longer really needed in 7.2.2+ as it exists in the Portal Settings UX now.
Aug 2, 2014 at 3:37 PM
Edited Aug 2, 2014 at 3:51 PM
Weird, i do get the following error:

The page cannot be displayed because an internal server error has occurred.

website URL is: www1.lanova.nl
non-existing page: www1.lanova.nl/test

in the module the 404 is redirecting to: www1.lanova.nl/404-error-page

could this be an IIS 8.5 issue?

When i look in my DNN web.config i see the following under <system.webserver>
<httpErrors>
  <remove statusCode="404" subStatusCode="-1" />
  <error statusCode="404" prefixLanguageFilePath="%SystemDrive%\inetpub\custerr" path="404.htm" responseMode="File" />
</httpErrors>
BTW you mean removing the 404 settings from the module? I wouldn't do that as yet.
The problem for me is that it's not present in my clean 7.2.2 install, and no one seems to be able to figure out why.
That's the whole reason that i installed the x3 URL management module.

I also cannot upgrade to 7.3.0 or 7.3.1 since there are some issues with some scripts in my skin that need to be fixed first.
Aug 2, 2014 at 3:56 PM
Interesting. I haven't messed around with IIS 8.5 yet. But I don't have any of those web.config entries.

Strange that 7.2.2 doesn't have the 404 setting on the Portal Setting UX since that is when they moved it, maybe they just forgot to add it to the UX. I'll leave it in since they both go to the same place.
Aug 2, 2014 at 4:22 PM
Edited Aug 2, 2014 at 4:56 PM
That's very interesting then indeed. Since you did not have them in your web.config, i just deleted thos lines and now the 404 redirect seems to function properly...

lines deleted under <system.webserver>

<httpErrors>
<remove statusCode="404" subStatusCode="-1" />
<error statusCode="404" prefixLanguageFilePath="%SystemDrive%\inetpub\custerr" path="404.htm" responseMode="File" />
</httpErrors>

Now the question is, how did these entries come in here, can it be inherited from a system default in IIS8.5?